GPS Week Rollover

What Is the GPS Rollover Bug?

Starting April 6, 2019, a global GPS time reset issue, dubbed GPS Week Rollover, may impact location accuracy when making a 911 call from a mobile device.

As a result of the GPS rollover, some Koodo customers using select mobile devices may not have accurate GPS location readings in the event of a 911 emergency (see below for a list of affected devices). More specifically, when customers using the affected mobile devices make a 911 call, emergency services will receive the call, however, they may not have the ability to detect the customers’ exact GPS location coordinates.

This is a global issue and not isolated to Koodo.

What Koodo is Doing

Koodo is working with manufacturers to roll out fixes to affected devices as soon as possible. However, some devices will not receive software patches for the foreseeable future.

Our customers’ safety is an absolute priority and we will advise impacted Koodo customers via SMS in advance of April 6th, to make them aware of the following:

  • If a customer is making making a 911 call using one of the impacted devices, we suggest that they exercise caution and provide EMS with their location details.
  • Download software patch as soon as possible for devices with an available software update
  • For customers with a device without a known software patch, we are advising them to be aware of this issue and exercise caution if they find themselves in a 911 situation, including sharing their specific location with emergency services.

Affected Devices

Koodo has identified a small number of select devices that, as of April 6th, 2019, will no longer provide accurate location functionality. These devices may, however, obtain some location functionality through wireless tower triangulation so Emergency Services may continue to get locations for these customers. Koodo will communicate to all impacted customers to make them aware of this issue and encourage them to download the applicable software patch to their devices to resolve this issue.

Koodo has worked with manufacturers to roll out fixes to affected devices. If your device is listed below, please update your devices to the latest software.

  • Alcatel A50 (5085O)
  • Alcatel 1 (5033O)
  • Alcatel Lume (A466T)
  • Alcatel Pixi 3(4) (A460T)
  • Alcatel Pixi 3(4.5) (5017O)

Some devices, however, will not receive software patches due to their age. If your device is listed below, please be aware of this issue and exercise caution if you find yourself in a 911 situation. Alternatively, you can visit your nearest Koodo store to purchase a new device.

  • Alcatel A392A / A392CC
  • Alcatel Idol X+ (6043A)
  • RIM BlackBerry Curve (9320)
  • RIM BlackBerry Curve 3G (9300)
  • RIM BlackBerry Torch (9800)
  • RIM BlackBerry Bold (9700)
  • RIM BlackBerry Curve (9360)
  • RIM BlackBerry Bold (9780)
  • RIM BlackBerry Bold (9790)
  • HUAWEI Ascend Y330
  • HTC Desire 320a (0PF1100)
  • Motorola Charm (MB502)
  • Motorola Defy (MB525)
  • Motorola Key (EX225)
  • Motorola Milestone (A853)
  • Nokia 3710
  • Nokia E71
  • Nokia E72
  • Sonim XP5560
  • Sonim XP5560IS
We are constantly finding ways to improve our service and the feedback you leave here helps us to do that. However, we can’t respond to individual messages from this form.

Need more help?

Visit the Koodo Community.

Check it out