Language
Region
Language
Region

Wireless public alerting compatible devices

Not all wireless mobile devices offer wireless public alerting compatibility. The following devices have been tested and certified by Koodo for emergency alerting compatibility. If your device is on the list, you should also make sure to have the latest available software for your device to ensure you have the emergency alerting functionality. Koodo can only guarantee WPA compatibility for devices listed here. Older device models might not have WPA functionality enabled by the device manufacturer. For more information, you can contact your device manufacturer.

Alcatel A50, Alcatel 1, Go Flip, Pixi 4, Pixi 5, U50, 3T8

Apple Apple Watch 3, Apple Watch 4, Apple Watch 5, iPhone SE, iPhone 5s, iPhone 6, iPhone 6 Plus, iPhone 6s, iPhone 6s Plus, iPhone 7, iPhone 7 Plus, iPhone 8, iPhone 8 Plus, iPhone X, iPhone XR, iPhone XS, iPhone XS Max, iPhone 11, iPhone 11 Pro, iPhone 11 Pro Max

*Requires iOS version 11.3 or newer for WPA support

BlackBerry DTEK50, KEYone, Key2, Motion, Priv, Key2 LE

Essential Essential Phone

Google Pixel, Pixel XL, Pixel 2, Pixel 2 XL, Pixel 3, Pixel 3 XL

Huawei Nexus 6P, P20, P20 Pro, Mate 20 Pro, P30, P30 Pro

LG LG G5, LG G6, LG G7 ThinQ, LG Nexus 5X, LG Q6, LG V30, LG X power3, LG G7 One, LG Q Stylo+, LG K9, LG X Power 2, LG X Power 3, LG K20, LG K30

Motorola Moto G Play, Moto G7 Play, Nexus 6, Moto X Play, Moto Z, Moto Z Play, Moto E6, One Vision

Samsung Galaxy A8, Galaxy J1, Galaxy J3, Galaxy J3 Prime, Galaxy J3 Top, Galaxy J3 Prime, Galaxy Note5, Galaxy Note8, Galaxy Note9, Galaxy S6, Galaxy S6 Edge, Galaxy S6 Edge+, Galaxy S7, Galaxy S7 Edge, Galaxy S8, Galaxy S8+, Galaxy S9, Galaxy S9+, Galaxy Tab A (2017), Galaxy XCover 4, Samsung A5, J3 Top, Galaxy Watch S4, Galaxy Watch S4 Small, Galaxy S10, Galaxy S10+, Galaxy S10e, Note 10, Note 10+, Galaxy A70, Galaxy A50, Galaxy A20

Sonim XP3800, XP5800, XP8800

Coolpad Snap


Was this article helpful?

Need more help?

Visit the Koodo Community.